Connect Home Connect Home
Sign up| Login

Group discussion > openQA worker service status inactive (dead)

openQA worker service status inactive (dead)

elen
1443 days ago

Hello! I need some help, I am new with OpenQA.
when I  try to start (systemctl start openqa-worker@1.service) a worker I am not be able to change the status to Active (running). do you know why?
systemctl status -l openqa-worker@1.service
openqa-worker@1.service - openQA Worker #1
   Loaded: loaded (/usr/lib/systemd/system/openqa-worker@.service; enabled)
   Active: inactive (dead) since Wed 2015-12-09 12:21:58 CET; 1h 37min ago
  Process: 2515 ExecStart=/usr/share/openqa/script/worker --instance %i (code=exited, status=0/SUCCESS)
  Process: 2514 ExecStartPre=/usr/bin/install -d -m 0755 -o %u /var/lib/openqa/pool/%i (code=exited, status=0/SUCCESS)
 Main PID: 2515 (code=exited, status=0/SUCCESS)
Dec 09 12:21:58 dockerMaster worker[2515]: server refused with code 404: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
Dec 09 12:21:58 dockerMaster worker[2515]: <html><head>
Dec 09 12:21:58 dockerMaster worker[2515]: <title>404 Not Found</title>
Dec 09 12:21:58 dockerMaster worker[2515]: </head><body>
Dec 09 12:21:58 dockerMaster worker[2515]: <h1>Not Found</h1>
Dec 09 12:21:58 dockerMaster worker[2515]: <p>The requested URL /api/v1/workers was not found on this server.</p>
Dec 09 12:21:58 dockerMaster worker[2515]: <p>Additionally, a 404 Not Found
Dec 09 12:21:58 dockerMaster worker[2515]: error was encountered while trying to use an ErrorDocument to handle the request.</p>
Dec 09 12:21:58 dockerMaster worker[2515]: </body></html>