Connect Home Connect Home
Sign up| Login

Group discussion > Power off or restart delay too much. I think they don't work

Power off or restart delay too much. I think they don't work

Efstathios Iosifidis
3119 days ago

Hello,

When I try either to power off my computer or restart it, I get the dialog to wait but the procedure delay, I think it never finish.

So if I want to power off, either I log out and I turn it off from the password prompt screen, or use the shutdown -h now command.

Is there a problem? Do I have to change some permissions or something?

Thanks for your help

Alex-P. Natsios
3119 days ago

Do you have a lot of apps running before pressing the button?
In that case sometimes E tends to choke on and fail to notify you about apps that do not exit, thus you get no message while E is waiting for the apps to exit and shutdown your machine.

Tomáš Čech
3119 days ago

Check contents of your /etc/enlightenment/sysactions.conf file. If your halt line looks like:

action:   halt      /sbin/shutdown -h now

You will need to set SUID bit for /usr/lib64/enlightenment/utils/enlightenment_sys. I had to disable SUID bit for some files so it can pass openSUSE security audit. Current version will have this problem.

You can also alter line in your configuration to perform DBUS call to UPower so you don't need to use SUID binary:

action:   halt         dbus-send --print-reply=literal --system --dest=org.freedesktop.systemd1 /org/freedesktop/systemd1 org.f
reedesktop.systemd1.Manager.PowerOff

If you have your installation for a long time, it is possible, that you don't have your configuration with these lines. This file is not overwritten during updates.

martinrehm
3118 days ago

Ah ja, have to check this.

Workaround here is >log out with fallback to KDM, then >shut down and confirm >shut down

 

Martin 

Efstathios Iosifidis
3118 days ago

My installation is new.

The lines of the sysactions.conf are

action:   halt       dbus-send --print-reply=literal --system --dest=org.freedesktop.systemd1 /org/freedesktop/systemd1 org.freedesktop.systemd1.Manager.PowerOff

action:   reboot       dbus-send --print-reply=literal --system --dest=org.freedesktop.systemd1 /org/freedesktop/systemd1 org.freedesktop.systemd1.Manager.Reboot

What do you suggest me to do?

Tomáš Čech
3118 days ago

Ok, problem reproduced. The problem is insufficient permissions for this DBUS call:

You can probably find similar message in your ~/.xsession-errors like this:

Error org.freedesktop.DBus.Error.AccessDenied: Rejected send message, 2 matched rules; type="method_call", sender=":1.56" (uid=1000 pid=3842 comm="dbus-send --print-reply=literal --system --dest=or") interface="org.freedesktop.systemd1.Manager" member="PowerOff" error name="(unset)" requested_reply="0" destination="org.freedesktop.systemd1" (uid=0 pid=1 comm="/sbin/init ")

This was working with suid bit, but it requires some additional settings now. I'll investigate it.

Tomáš Čech
3116 days ago

I believe that shutdown/reboot should work with the latest Factory version after build is finished. This time your update will overwrite /etc/enlightenment/sysactions.conf to fix it.

Efstathios Iosifidis
3107 days ago

After omega update, shutdown and restart work fine.