Connect Home Connect Home
Sign up| Login

Group discussion > [SOLVED] Terminology doesn't write Greek letters

[SOLVED] Terminology doesn't write Greek letters

Efstathios Iosifidis
484 days ago

Well, when I open terminology and write a command, it's working fine. But if I have a directory or fle in Greek, it doesn't write in Greek. Is it my computer's fault or terminology?

Tomáš Čech
483 days ago

If you are able to write in other applications, but not in Terminology (and you don't have per application specific keyboard configuration), it's Terminology's fault.

Are you able to write Greek letters into lets say Konsole, Gnome/XFCE/LXDE Terminal or URxVT? (Try one)

Efstathios Iosifidis
483 days ago

I can write in Greek into other terminals (Gnome).

Here is the picture. After the word English, it's in Greek.

Tomáš Čech
483 days ago

Please, file a bug about that at http://trac.enlightenment.org/e/newticket

Efstathios Iosifidis
483 days ago

Tomas, not sure if it's a bug. Please tell me if it is.

I changed fonts to fifth leg (to look more openSUSE) and it writes Greek.

Maybe file a bug to change the default font to utf-8 or something?

Tomáš Čech
483 days ago

Terminology with the font FifthLeg with some Greek letters: http://www.enlightenment.org/ss/e-50dd7175e76e12.46566431.png

This was copy & paste, but not the problem of a font.

So I tried to set XKB to produce Greek characters with keyboard: http://www.enlightenment.org/ss/e-50dd724954dcf6.98500954.png

Changing the same screen to Nexus (that is default? I use Terminus...) looks then like:

http://www.enlightenment.org/ss/e-50dd72dd7bb698.78676854.png

So it looks like default font is not capable of Greek letters.

Efstathios Iosifidis
483 days ago

Tomas, can you write in your language? Is it only Greek or other languages too?

Tomáš Čech
483 days ago

I don't use default font as I found it hard to read and I always used Terminus. I have no problems in Terminus with Czech or Greek. But there is missing support for katakana, hiragana, kanji and a lot of other alphabets too I'm sure. If you want some complete set, use Unifont or similar.

Alex-P. Natsios
482 days ago

I too am unable to write in Greek, i don't think its just a font issue.
I can see Greek characters (terminus) but can't input any non-latin language.

Tomáš Čech
481 days ago

Does Terminology produce some errors? (run Terminology from Xterm and check, what it is producing)

Could you check also ~/.xsession-errors and check for errors? Also provide output of

grep setxkbmap ~/.xsession-errors | tail -n 10

Also please try to set Numlock on if it works as workaround. There is some known issue with not showing all emmited characters.

Agust17
481 days ago

My problem with Terminology is:

"segv with scrolling output"

Same here:

http://trac.enlightenment.org/e/ticket/2117

 

Efstathios Iosifidis
481 days ago

Running terminology from Gnome terminal I get the result:

ERR<1601>:elementary elm_scroller.c:734 elm_scroller_policy_set() Passing object (0x8e77b48) of type 'entry' in function elm_scroller_policy_set, but it doesn't implement the Elementary scrollable interface.

ERR<1614>:efreet_desktop efreet_desktop.c:803 efreet_desktop_generic_fields_parse() efreet_desktop_generic_fields_parse error: no Name or _Name fields

And the result of the command grep setxkbmap ~/.xsession-errors | tail -n 10 is (one line):

SET XKB RUN: setxkbmap -layout 'us,gr,' -variant ',,' -model 'default' -option  -option 'grp:alt_shift_toggle'
We need Greek or other languages because users save their files-folders under their native language.

Tomáš Čech
481 days ago

ERR<1601>:elementary elm_scroller.c:734 elm_scroller_policy_set() Passing object (0x8e77b48) of type 'entry' in function elm_scroller_policy_set, but it doesn't implement the Elementary scrollable interface.

I have the same, doesn't bother me for this now.


ERR<1614>:efreet_desktop efreet_desktop.c:803 efreet_desktop_generic_fields_parse() efreet_desktop_generic_fields_parse error: no Name or _Name fields

I have found that I had file /home/tcech/.local/share/applications/unnamed_desktop.desktop which was causing this. It seems to be related to rhytmbox, but I don't know where does it come from. I believe it is save to delete it.

 

SET XKB RUN: setxkbmap -layout 'us,gr,' -variant ',,' -model 'default' -option  -option 'grp:alt_shift_toggle'
We need Greek or other languages because users save their files-folders under their native language.
Thanks. I'm aware of importance of this. I just can't reproduce it in my environment. I tried to set xkb the same way as you did and I'm able to insert Greek characters. Please, file a bug in bugzilla and let's do that thoroughly, I'll need logs and other information and bugzilla is better tool for bug hunt. Thanks.
Assign that to me of course.

Tomáš Čech
477 days ago

As I still don't see any bug in bugzilla assigned to me, I made one by myself. Please, add there the info as described in Portal.

Efstathios Iosifidis
476 days ago

Tomas, sorry for the delay. I added the files according to Portal. Please let me know if you need anything else.

Thanks

Tomáš Čech
476 days ago

Thank you for the files. But as I understand your last comment, changing font fixes your issue, this is expected.

I need logs from Alex-P. Natsios because as he thinks his problem is not font related...

Alex-P. Natsios
476 days ago

Alex might think that .. but there are times he thinks about the wrong stuff.

its due to the way i setup stuff to be cross-distro/cross-wm ignore it.
After a few changes to my setup (and unloading e-keyboard-module) with a font that supports Greek glyphs i too can write in Greek , just like stathis.

Tomáš Čech
475 days ago

Ok, I'll close the bug again. Feel free to reopen if necesary and please provide there all that basic information I requested.