Connect Home Connect Home
Sign up| Login

Group discussion > [SOLVED] edje_cc ?

[SOLVED] edje_cc ?

Agust17
479 days ago

Well , when I try to compile a theme I get this error:

"Compling script code not clean"

Installed:

edje , edje utils , libedje1 , phyton edje.


You have to install any dependencies in edje ? , thanks

Tomáš Čech
479 days ago

I have seen this error already. I haven't found anyone who would answer my question what is wrong with that. It is packaging issue. Installing edje-devel will fix that. It seems that some package from edje-devel should go to edje.

Agust17
479 days ago

Hi Tomas , I owe you a beer, actually with the package "edje-devel" is fixed.

Thanks!!!!!

Efstathios Iosifidis
479 days ago

You owe a Czech guy a beer? Funny!!!

By the way, do I have to install edje-devel too? I don't create themes.

The ones that Agust made are super!!!

Agust17
479 days ago

LoL!!! Efstathios , OK! Tomas I will invite you to an orange juice.

Look here to see if they like.

http://www.enlightenment.org/ss/display.php?image=e-50e07ef1142750.86910024.jpg

simotek
479 days ago

Well that explains why it wasn't working on my VM but was on my main machine

Tomáš Čech
478 days ago

You have to install edje-devel now only for running edje_cc and similar. Users usually doesn't need to run these tools unless they're developers of EFL apps or theme creators or you'd like to compile some EFL applications from source.

Btw.it seems the problem is not any file from devel package but missing ependencies

Tomáš Čech
478 days ago

I believe this issue is finally fixed. Please, update and then you can remove edje-devel package again.

There were needed files from embryo-devel package. I moved them to embryo package and made edje requiring embryo.